View Issue Details

IDProjectCategoryView StatusLast Update
0028501RunnerWindowsPublic2018-10-29 16:26
ReporterDanAssigned ToFritz 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10OS VersionPro x64
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0028501: Windows: Setting a too-large room will cause game to fail in the GPU on startup, should try to guard this and better inform user
DescriptionSetting a too-large room will cause game to fail in the GPU on startup, causing multiple error dialogues to appear. We should try to guard this and better inform the user that this is due to trying to create a surface larger than the GPU can handle. Right now, the error dialogues you get aren't particularly helpful, as they're all very specific and technical about the issue.

If you create a new GMS2 project and simply change the default 1280x720 room to be 12800x7200 you will cause this on most GPUs, as you're not using a view to restrict the size of the application_surface on game start.

Expected: On game start we calculate the intended size of the application_surface and confirm that the GPU can handle this before attempting to create the surface. If the GPU cannot handle it, we show an error which says that the application_surface is too big for this GPU to handle and their room size should be smaller or they should use a view. OKing the dialogue gracefully closes the game.
Steps To Reproduce1. Run the attached project for Windows.
2. Observe you get a series of error dialogues (about 5 of them in a row).

Repro: 100%
Additional InformationThe "and their room size should be smaller or they should use a view" bit is probably only suitable during runs, not create exe, as the developer's PC might have been fine, but their customer's PC is not...
Tagsrendering, Runner
1.4 Found In
2.x Runtime Found In2.1.2.172
2.x Runtime Verified In2.2.1.269

Activities

Dan

2017-12-07 17:30

Adminstrator  

largerroomerror.yyz (17,435 bytes)