View Issue Details

IDProjectCategoryView StatusLast Update
00284992.x IDE BugsSound EditorPublic2021-07-16 14:05
ReporterSam CummingAssigned ToCoreTech 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
PlatformOSmacOS SierraOS Version
Product Version2.1.3 
Target VersionFixed in Version 
Summary0028499: Sound Editor: [Mac IDE] Low-powered Macs struggle to play audio in Sound Editor
DescriptionIf you try to play a sound in the Sound Editor on a low-power Mac, such as DanMac, the Mac will struggle to play the sound consistently, and will run at a reduced speed.

On DanMac, the audio plays at almost half speed, and is choppy. If you loop the sound, it will eventually slow down so much that it will stop playing all together and get stuck, while registering on the IDE as still playing.
Steps To Reproduce1. On a low power Mac, open any project.
2. Open a sound.
3. Preview the sound.
4. Observe that the sound plays slowly and is choppy.
5. Loop the sound, allow it to play for a while.
6. Observe that the sound gets choppier and slower until it eventually stops.
Tagsaudio, IDE, mac
2.x IDE Found In2.1.3.271
2.x Runtime Found In2.1.3.187
2.x IDE Verified In
2.x Runtime Verified In

Relationships

child of 0028500 ResolvedCoreTech Sound Editor: [Mac IDE] Playing sounds in Sound Editor is very processor intensive 

Activities

Dan

2021-07-16 14:05

Adminstrator   ~0066365

Has been fixed or made invalid by changes in recent versions of GMS2. Closing.