View Issue Details

IDProjectCategoryView StatusLast Update
0028480RunnerExtensionsPublic2021-07-30 15:24
ReporterStewart BishopAssigned ToCoreTech 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionSuspended 
Product Version 
Target VersionFixed in Version 
Summary0028480: Extensions: Cancelling the login dialogue on the Facebook Extension doesn't throw the async event
DescriptionWhen attempting to login with facebook, a login dialog appears. if you cancel that dialog by pressing the back button before it appears, the async social event of facebook will never be called(neither as failed). It throws an exception:"Exception thrown trying to call method onActivityResult on FacebookExtension". You can find the exception at the file "RunnerJNLib.java" in the function "CallExtensionFunction". Its because one of the args is null, so getclass won't work for a null..

Fix:
To fix it go to the file: "RunnerFacebook.java" and replace the function onActivityResult to these lines:
public void onActivityResult(int requestCode, int resultCode, Intent data)
{

Object [] argArray = new Object[3];
argArray[0] = requestCode;
argArray[1] = resultCode;
argArray[2] = data;

//add these 3 lines:
if(argArray[2] == null) {
argArray[2] = new Intent();
}
RunnerJNILib.CallExtensionFunction("FacebookExtension","onActivityResult",3,argArray);
}
Tagsfacebook
1.4 Found In1.4.1772
2.x Runtime Found In2.1.2.172
2.x Runtime Verified In

Activities

SamH

2021-07-30 15:24

Developer   ~0066560

Unable to confirm now. If this still happens in the current GMS2 release, then we will investigate a fresh report. Closing.