View Issue Details

IDProjectCategoryView StatusLast Update
0028453RunnerHTML5Public2018-10-31 10:53
ReporterParodyKnaveBobAssigned ToAlan Savage 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSWindowsOS Version
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0028453: HTML5: Debugger fails to load instance list in Microsoft browsers
DescriptionWhen running a game from GMS v1.4.1773 in debug mode on the HTML5 target, the instance list (in the debugger's center panel) fails to load on the latest Microsoft Edge and Internet Explorer 11. The three panels exist, but only the leftmost (console-ish output) displays any information.

Latest stable builds for Chrome and Firefox build fine and show the instance(s) in the debugger's center list, clickable to show built-in variables in the rightmost panel. I haven't tested any browsers besides these four.

I'm not really surprised it fails on IE11, which also logs an error each on gpu_get/set_alphatestenable(), but Edge shouldn't have any problems with this...
Steps To Reproduce1. New project, new room0.
2. New object0.
3. Place instance(s) of object0 into room0.
4. F6, targeting HTML5.
Tagshtml5, Runner
1.4 Found In1.4.1773
2.x Runtime Found In
2.x Runtime Verified In2.2.1.273

Activities

ParodyKnaveBob

2017-12-01 05:29

Updater  

instance-in-room-for-HTML5-debugger.gmz (315,443 bytes)

ParodyKnaveBob

2017-12-02 00:19

Updater   ~0056844

My "Additional Information" uses IE11's gpu_*() error messages as an off-hand comparative example of deficient quality, but I've since found that's probably entirely irrelevant: see 0028459.

Dan

2018-09-27 14:04

Adminstrator   ~0061627

I know you recommend Chrome to do most testing. 1. You also know it's still good to test in other browsers. 2. I'd actually *prefer* to do most my testing in Edge because for the most part I'd rather not divvy up my low-end hardware's resources on multiple browsers (where I prefer to use Edge for my day-to-day research, fun, etc.).