View Issue Details

IDProjectCategoryView StatusLast Update
00283762.x IDE BugsSprite EditorPublic2019-02-14 17:00
ReporterKevin BrownAssigned ToSteven Campbell 
PriorityVery HighSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product VersionPre-2.1.3 
Target Version2.1.4Fixed in Version2.2.2 
Summary0028376: Sprite Editor: [Precise overrides Manual mask values, but the editor does not communicate this properly]
DescriptionSprites with Manual & Precise collision masks should only cause collisions with the non-empty pixels of the sprite within the rectangular area that is specified.
Steps To ReproduceOpen the attached .yyz
Run with target Windows
Move around with the arrow keys
Notice that you collide with all visible parts of the objects
Open spr_gate & sprite4
Notice that they both have Manual & Precise collision masks for only a section of the sprite
TagsNo tags attached.
2.x IDE Found In2.1.2.257
2.x Runtime Found In2.1.2.172
2.x IDE Verified In2.2.2.393
2.x Runtime Verified In2.2.2.308

Activities

Kevin Brown

2017-11-21 09:54

Manager  

136967.yyz (36,465 bytes)

Dan

2017-11-22 10:53

Adminstrator   ~0056734

Last edited: 2017-11-22 11:04

View 2 revisions

This is a possible misunderstanding of the behaviour of "Precise" mixed with a definite UI issue in that we don't disable the Manual/auto dropdown, resize the mask area to fit the precise shape, and then block changing the mask handles when Precise is chosen in order to communicate that Precise is all pixels in your sprite.

Accordingly, Precise (across the whole image) is what's being used in-game, but in the IDE it looks to the end user like they should be able to have precise collisions ONLY within their masked area and everything outside the masked area would be ignored.

Dan

2017-11-22 11:00

Adminstrator   ~0056735

Last edited: 2017-11-22 11:05

View 2 revisions

This is due to a change in http://bugs.yoyogames.com/view.php?id=25174 to give exactly this situation.

http://bugs.yoyogames.com/view.php?id=27273 is also related.

Suspect that if the change to fix the 1.4/2.x discrepancy is indeed correct, then the sprite editor should have been altered at that time to disable the Manual fields and recalculate the mask to the precise shape, as I suggested above.

Dan

2017-11-22 11:05

Adminstrator   ~0056736

Change the sprite editor to reflect Precise always takes precedence?

Steven Campbell

2018-02-16 14:25

Manager   ~0057770

Closing as the inverse of 0025174

Have removed the code in GitLab Merge Request 464
Git Id: 4269a1aed2dd12dc41624ed773e8edd620627ebf

Matthew McInnes

2019-02-14 17:00

Developer   ~0063209

Closing. Verified as fixed in:

Beta IDE v2.2.2.393 Beta Runtime v2.2.2.308