View Issue Details

IDProjectCategoryView StatusLast Update
00281612.x IDE BugsDevice ManagerPublic2021-07-21 13:48
ReporterSam CummingAssigned ToCoreTech 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
Product Version 
Target VersionFixed in Version 
Summary0028161: Device Manager: Disconnected iOS devices are forgotten when 'Detect Device' is clicked
DescriptionIf you have several iOS devices in your Device Manager, when you click 'Detect Device', these disconnected devices will be forgotten, and will have to be added again manually.

The Android page remembers Android devices that are no longer connected when 'Detect Device' is clicked, so iOS should also remember disconnected devices to maintain consistency.

Steps To Reproduce1. Open any project.
2. Attach an iOS device.
3. Click 'Detect Device', wait until your device has been detected.
4. Remove the iOS device from your Mac.
5. Click 'Detect Device' again, observe that your iOS device has been forgotten.
TagsIDE, target_manager
2.x IDE Found In2.1.2.253
2.x Runtime Found In2.1.2.169
2.x IDE Verified In2.1.1.2
2.x Runtime Verified In2.1.1.1

Activities

Mike Dailly

2017-11-01 14:31

Developer   ~0056386

Devices "saved" into your list should not be deleted (same as Android)

Dan

2018-01-08 16:19

Adminstrator   ~0057222

#0027497 implies that this issue is not limited to iOS (unless Steven did fix Android specifically, but never updated that original report).

SamH

2021-07-21 13:48

Developer   ~0066443

Unable to confirm now, however the issue is fixed for Android. If this still happens in the current GMS2 release, then we will investigate a fresh report. Closing.