View Issue Details

IDProjectCategoryView StatusLast Update
00281572.x IDE BugsSource ControlPublic2018-10-30 11:05
ReporterSam CummingAssigned ToSteven Campbell 
PriorityHighSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0028157: Source Control: 'Import Project to Repo' creates local repo if the import fails, preventing further imports
DescriptionIf you try to import a project to a repo, if this fails in any way (credentials failure for example), the IDE will create a local .git folder, which will then prevent you from importing the project to a repo again.

Expected: If 'Import Project to Repo' fails, do not create a local .git folder, and allow the user to try again once they've fixed the problem.
Steps To Reproduce1. Open any new project.
2. Create a few assets.
3. Go to GitHub or Bitbucket, create a repo.
4. Go to your preferences, remove your Git credentials apart from Username and Email.
5. Attempt to import your project into the repo you created online.
6. Observe that this will fail, stating that your credentials are invalid.
7. Open the project folder in explorer, observe a .git folder.
8. Try to import your project to the repo again, observe that this option is greyed out.
TagsNo tags attached.
2.x IDE Found In2.1.2.253
2.x Runtime Found In2.1.2.169
2.x IDE Verified In2.2.1.357
2.x Runtime Verified In2.2.1.269

Relationships

related to 0028158 AssignedCoreTech Source Control: Deleting the .git folder in a project will crash the IDE when it tries to save 

Activities

Sam Cumming

2017-11-16 15:37

Developer   ~0056656

Looks like GitHub and Bitbucket handle credential passing differently, so they come in a different order which can upset Import Into Repo.

Git doesn't clean up after it, leaves the .git folder, but Bitbucket does, no .git folder left behind.

Steven Campbell

2017-11-17 14:25

Manager   ~0056698

Fixed in Red IDE/GitHub Pull Request 3848
Git Id: b8326e998bf4fe8b52f006b3742e2fbca69c7bbe (main fix)
and 7eb5803a21f3dcb66400312d6dcbe97096c5bcb7 (recursive fixes)

Sam Cumming

2018-06-28 09:25

Developer   ~0060696

Currently unable to fully verify this one due to #29707, however I think this one is fixed. Will verify once the blocking bug is fixed.