View Issue Details

IDProjectCategoryView StatusLast Update
0028060RunnerHTML5Public2018-10-26 11:41
ReporterSam CummingAssigned ToMike Dailly 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OSOS Version
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0028060: HTML5: Surfaces existing outside of viewport will not render when inside viewport
DescriptionIf a surface was created outside of the viewport, when it eventually is inside the viewport, it will not be rendered at all.

The attached project illustrates this.
If you run it on Windows, the surface will render correctly regardless of where the viewport is. Note that the surface is large, use the arrow keys to scroll through it.

If you run this on HTML5, then use the arrow keys to move around, observe how small the area is. This is because surfaces outside of the viewport when they were spawned are effectively culled.
Steps To Reproduce1. Open the attached project.
2. Run it in Windows, observe correct result (Use arrow keys to navigate).
3. Run it in HTML5.
4. Observe that the surface is cut off. The surface is much smaller, and surfaces outside of the viewport when they spawned are culled.
Tagshtml5, rendering, Runner
1.4 Found In1.4.1773
2.x Runtime Found In2.1.2.160
2.x Runtime Verified In2.2.1.268

Activities

Kevin Brown

2017-10-13 16:49

Manager  

TestingHTML (2).gmz (19,917 bytes)