View Issue Details

IDProjectCategoryView StatusLast Update
00280142.x IDE BugsResource TreePublic2018-06-12 14:31
ReporterAlexander BorupAssigned ToClaire Hall 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version 
Target Version2.1.4Fixed in Version2.1.4 
Summary0028014: Resource Tree: Performance is very poor
DescriptionOpen a large project like Crashlands and expand all nodes through right-click menu. Notice that it becomes nearly unusable.
2.x IDE Found In2.1.0.212
2.x Runtime Found In2.1.0.136
2.x IDE Verified In2.1.4.284
2.x Runtime Verified In2.1.4.200

Activities

Chris Harrison

2017-11-17 10:50

Developer   ~0056680

Is the whole IDE unusable for you afterwards or just the resource tree (and dock)?

As far as I can tell the rest of the IDE's fine and it's easy enough to collapse-all again.

For a large project the collapse-all option is a waste of space as only a small fraction of the project will become visible as a result and we may want to consider having expand/collapse all for each node rather than only having a global feature.

Alexander Borup

2017-11-17 12:28

Developer   ~0056693

The performance problem is specific to the resource tree, I don't think the bug should have gone to you. It's the resource tree's layout update step that's gonna be taking a massively long time because the gadget hierarchy is overly complex.

Mike Dailly

2017-11-20 09:28

Manager   ~0056701

Should really just "clip" items to the resource tree view "window". And being hierarchical - and in a column, it should just "stop" processing once it's below the threshold.

Claire Hall

2018-02-21 14:26

Developer   ~0057829

Optimisation is waiting on a feature branch to be tested by QA before merging to master

Claire Hall

2018-03-07 14:18

Developer   ~0057993

General UI optimisations + specific stack panel optimisations, has potential to affect entire UI

Sam Cumming

2018-04-02 14:35

Adminstrator   ~0058499

Verified > 2.1.4.284 / rt 2.1.4.200 - There's still a slight performance hit on large projects, but only if all of the Resource Tree is expanded (and only when you're dragging assets around to reorder them). Other than that, the Resource Tree is very fast - Closing.