View Issue Details

IDProjectCategoryView StatusLast Update
0027885RunnerHTML5Public2018-02-07 14:52
ReporterYellowAfterlifeAssigned ToMike Dailly 
PriorityMediumSeverityA - Crash/HangReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 8OS Version8.1
Product Version 
Target VersionFixed in Version 
Summary0027885: HTML5: buffer_copy does not work due to a typo in code
DescriptionDue to function names being obfuscated it is hard to say what the actual typo is, but it's the last function call before "return" in the internal buffer_copy function and there isn't a function named so.

Code:

var b1 = buffer_create(32, buffer_fixed, 1);
var b2 = buffer_create(32, buffer_fixed, 1);
buffer_copy(b1, 0, 16, b2, 0);


1.4 Found In1.4.17
2.x Runtime Found In2.1.0.144
2.x Runtime Verified In

Activities

YellowAfterlife

2017-09-21 12:40

Developer  

png2.png (11,212 bytes)
png2.png (11,212 bytes)
a_bug.yyz (768,390 bytes)

Mike Dailly

2017-09-25 15:56

Manager   ~0055685

fixed in gitlab