View Issue Details

IDProjectCategoryView StatusLast Update
00278062.x IDE BugsSavingPublic2018-06-22 10:50
ReporterMark AlexanderAssigned ToDan 
PriorityHighSeverityB - MajorReproducibility<25%
Status ClosedResolutionDuplicate 
Product VersionPre-2.1.3 
Target Version2.1.5Fixed in Version2.1.5 
Summary0027806: Saving: Duplicating an object in the resource tree sometimes fails to duplicate its events also
DescriptionWhile working on a tutorial project I had to make a number of "button" objects, and so made one with some generic code then used the RMB menu option in the resource tree to duplicate it to create new buttons. However, I found that sometimes (about once every four duplicates) I'd open an event in the newly duplicated object and it'd be empty.
Steps To ReproduceCreate an object and add some code to the create event
Duplicate the object and then open it and open the create event
Note that it should have code
Now duplicate the duplicated object again
Open the create event and see it may or may not have code...
Repeat, duplicating the last duplicated object and checking the Create Event
Tags215
2.x IDE Found In2.1.1.219
2.x Runtime Found In2.1.1.141
2.x IDE Verified In
2.x Runtime Verified In

Relationships

duplicate of 0029390 ClosedAlan Savage Code Editor: Events 'lose' code when object name is changed but not committed 

Activities

Mark Alexander

2017-09-15 09:04

Developer  

Amazon Game Circle DUPLICATE BUG.yyz (4,893,145 bytes)
ui-2017-09-14-12-39-48.gz (42,067 bytes)
ui.log (56,913 bytes)

Mark Alexander

2017-09-15 09:04

Developer   ~0055502

I have supplied the project that I was working on when this happened as well as the last few UI log files in case it's of any use. In the test project, simply make duplicates of any button object and keep duplicating.

Alan Savage

2017-09-15 11:53

Developer   ~0055511

not getting this at all after a few hundred duplicates, on current dev and latest green (2.1.1.222); tested using synced DropBox folder for project save location as mark was doing, as well as local documents folder

Mark Alexander

2017-10-09 14:54

Developer   ~0056069

On 2.1.1.242 now and haven't had the issue again. :( Can probably close this...

Dan

2018-06-15 11:41

Adminstrator   ~0060379

We strongly believe this is a dupe of the core issue in 0029390 and that duplicating the resource is simply another route to having unsaved code with a name change pending, rather than being integral to reproduction.