View Issue Details

IDProjectCategoryView StatusLast Update
0027656RunnerViews / CamerasPublic2018-10-29 11:26
ReporterStewart BishopAssigned ToFritz 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0027656: Views / Cameras: Cameras stored in global variables do not seem to persist between rooms
DescriptionWhen I run the game, the first room after rm_init opens and the camera works exactly as intended. However, on moving to the next room, the whole room is shown in the top-left corner of the display, not zoomed in as in the previous room. Then, upon moving back to the first room, the same issue presents itself - the whole room is shown in the top-left hand corner of the display.

Interestingly, running the camera_create_view() code in the Room Start event fixes this problem, so I can solve the issue by creating a new camera at the beginning of each room and then destroying it at the end.
Steps To Reproduce1) Import project
2) Run it
3) See that this does the above behaviour
4) Open camera_init
5) Uncomment the first line
6) Run it again
7) See that this now works as expected
Tagsrendering, Runner
1.4 Found In
2.x Runtime Found In2.1.0.136
2.x Runtime Verified In2.2.1.268

Activities

There are no notes attached to this issue.