View Issue Details

IDProjectCategoryView StatusLast Update
00275302.x IDE BugsDebuggerPublic2021-07-22 11:04
ReporterStewart BishopAssigned ToCoreTech 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionSuspended 
Product Version 
Target VersionFixed in Version 
Summary0027530: Debugger: Debugging iOS whilst suppress is on doesn't work
DescriptionIf you have suppress build enabled and then try to debug iOS this will just completely ignore the fact that you are trying to debug your game and instead just do a normal "suppress build" run, punting you off to Xcode and not caring at all.

We should either show a dialogue asking do you want to temporarily turn off suppress and then continue with a normal debug run, or we should do the suppress build as normal but also open the debugger so it is ready for when you've built your game within Xcode.
Steps To Reproduce1) Within preferences enable suppress build for iOS
2) Target iOS
3) Debug
4) See that this didn't debug
TagsBuild, IDE, igor
2.x IDE Found In2.1.0.204
2.x Runtime Found In2.1.0.135
2.x IDE Verified In
2.x Runtime Verified In

Activities

SamH

2021-07-22 11:04

Developer   ~0066456

Unable to reproduce now. If this still happens in the current GMS2 release, then we will investigate a fresh report. Closing.