View Issue Details

IDProjectCategoryView StatusLast Update
00272732.x IDE BugsSprite EditorPublic2018-06-12 14:27
ReporterDanAssigned ToAlexander Borup 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version 
Target VersionFixed in Version 
Summary0027273: Sprite Editor: Does not allow editing of bounding box values when using a precise collision type, should still do this
DescriptionThe Sprite Editor does not allow editing of bounding box values when using a precise collision type, but it should still do this as 1.4 allows it, so this will break compatibility with some 1.4 projects.

Expected: If I set the collision mode as manual, then I always have control over the four bbox text fields.
Steps To Reproduce1. Start GMS2 adn create a new project.
2. Create a new sprite.
3. Edit the sprite and add some random squiggle line drawing content into the sprite (not a solid fill colour!) and close the image editor.
4. Back in the sprite editor, expand the collision dropdown and set the type to be precise or precise per-frame. Then toggle the mask mode to "Manual".
5. Observe even though you're in manual mode, because the type is precise, the four text fields for the bbox remain locked.

Repro: 100%
TagsNo tags attached.
2.x IDE Found In2.0.7.171
2.x Runtime Found In2.0.7.110
2.x IDE Verified In2.1.1.234
2.x Runtime Verified In2.1.1.154

Activities

Dan

2017-08-02 17:09

Adminstrator  

Sam Cumming

2017-09-29 10:56

Developer   ~0055797

Verified > 2.1.1.234 / rt 2.1.1.154 - Closing.