View Issue Details

IDProjectCategoryView StatusLast Update
00271822.x IDE BugsSound EditorPublic2019-01-04 16:43
ReporterSam CummingAssigned ToSteven Campbell 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0027182: Sound Editor: Clicking on the playback bar while a sound is playing will not change the playback position
DescriptionIf you click on the playback bar while a sound is playing, the playback position will not change (however the playback head will momentarily jump to where you click, before resetting back to the current playback position).

As I understand this is due to async playback, FFMpeg and the UI outpacing the user.
Steps To Reproduce1. Open the Sound Editor and load a sound.
2. Play the sound.
3. Click anywhere on the playback bar.
4. Observe how the playback head jumps to where you click, before resetting to the current playback position.
TagsNo tags attached.
2.x IDE Found In2.1.0.184
2.x Runtime Found In2.1.0.121
2.x IDE Verified In2.2.1.355
2.x Runtime Verified In2.2.1.268

Activities

Sam Cumming

2017-07-24 11:19

Developer  

Steven Campbell

2017-07-25 11:25

Manager   ~0054514

Best bet at the moment is dragging the thumb /\
And yes, it's the communication back and forth which is causing the issue...
Slider gets updated based on the play position from FFmpeg every frame, so by the time you click in the slider to set your own, FFmpeg has returned with a new location, so it jumps about and doesn't necessarily go to where you clicked if you're out of sync with it.
It's a tricky one..

Russell Kay

2018-05-14 12:02

Manager   ~0059666

Unable to reproduce in v9.2.1.1416 - there is still an issue with it giving a flash just before it commits to the new play position (but that would be a separate bug) - it commits to the new play point without incident

Sam Cumming

2018-06-26 15:12

Developer   ~0060644

For Russell's new bug: https://bugs.yoyogames.com/view.php?id=29718

Sam Cumming

2018-06-26 15:21

Developer   ~0060645

Updated bug summary, description and repro to remove ambiguity.

Steven Campbell

2018-08-01 15:42

Manager   ~0061003

Fixed in IDE/GitHub Pull Request 4228
Git Id: 3da6b4fe3f46f3cb6df8fd1c61dd165577a92290