View Issue Details

IDProjectCategoryView StatusLast Update
00269202.x IDE BugsOutput WindowPublic2018-09-17 12:31
ReporterRoss ManthorpAssigned ToBrian Morrice 
PriorityHighSeverityC - GeneralReproducibility100%
Status ResolvedResolutionReopened 
PlatformmacOSOSOS X El CapitanOS Version10.11.6
Product VersionPre-2.1.3 
Target VersionPre-2.1.3Fixed in VersionPre-2.1.3 
Summary0026920: Output Window: [Mac IDE] show_debug_message doesn't work on Mac IDE
Descriptionshow_debug_message doesn't work on Mac IDE - it doesn't display anything in the Output window like it does on Windows.
TagsNo tags attached.
2.x IDE Found In2.0.7.171
2.x Runtime Found In2.0.7.110
2.x IDE Verified In2.1.1.241
2.x Runtime Verified In2.1.1.158

Activities

Russell Kay

2017-08-03 14:38

Manager   ~0054762

Fixed in gitlab for VM builds currently (will look into YYC builds)

Dan

2017-08-15 14:24

Adminstrator   ~0054915

YYC?

Chris Harrison

2017-09-04 11:46

Developer   ~0055245

Requires new runtime.

Ross Manthorp

2017-10-05 17:59

Adminstrator   ~0055974

IDE v2.1.1.241 Runtime v2.1.1.158

Sam Cumming

2017-12-18 11:36

Developer   ~0057083

Last edited: 2017-12-18 11:37

View 2 revisions

Replicated > 2.1.3.273 / rt 2.1.3.189 - This seems to be occurring again on Sierra machines. High Sierra appears to be unaffected.

Sierra machines output this in Output when trying to use show_debug_message: tail: /var/folders/kf/z6x4kd0s2bq3tfm641ltp4kh0000gn/GameMakerStudio2/GMS2TEMP/PROJ_VM/debug.log: No such file or directory

Compiling and pushing to Ubuntu from Mac works fine and will display the debug message in the Ubuntu local console

Chris Harrison

2017-12-19 14:04

Developer   ~0057106

Needs new runtime.

Chris Harrison

2018-03-26 09:03

Developer   ~0058348

Last edited: 2018-03-26 09:03

View 2 revisions

What version of the IDE/runtime is that user on and can I get a full output log please? I need more than a couple of screenshots if no-one else is reporting it as a problem and I can't reproduce it.