View Issue Details

IDProjectCategoryView StatusLast Update
0026608RunnerShadersPublic2018-10-25 15:06
ReporterStewart BishopAssigned ToMike Dailly 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0026608: Shaders: [GMS2] Draw failed due to invalid input layout
DescriptionWhen using vertex_usage_blendindices and vertex_usage_blendindeces within a custom vertex format and then calling shader_set this will constantly throw the error "Draw failed due to invalid input layout"
Steps To Reproduce1) Import attached project
2) Run it
3) See that the log spams this error
4) Open the object
5) Comment out the shader_set and reset
6) Run it again
7) See that this now draws again but no error
Tagsrendering, Runner, Shaders
1.4 Found In
2.x Runtime Found In2.0.6.96
2.x Runtime Verified In2.2.1.268

Activities

Stewart Bishop

2017-05-22 15:17

Developer  

vertex_usage_blendindices.yyz (13,605 bytes)