View Issue Details

IDProjectCategoryView StatusLast Update
0026524RunnerFontPublic2019-01-04 16:01
ReporterStewart BishopAssigned ToRussell Kay 
PriorityHighSeverityC - GeneralReproducibility100%
Status ClosedResolutionUnable To Reproduce 
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0026524: Font: [GMS2] Font gets messed up when resizing the game window and adapting the application surface and GUI size
DescriptionI use the following script to detect whether the player has resized the window:
/// @description window_resize()
var w = window_get_width();
var h = window_get_height();
if w <= 0 or h <= 0{exit;}
if w != surface_get_width(application_surface) or h != surface_get_height(application_surface)
{
surface_resize(application_surface, w, h);
display_set_gui_size(w, h);
view_set_wport(0, w);
view_set_hport(0, h);
}

The font seems to get "cut off", but only if you use a different font than the default font. In the example I use Arial
Steps To Reproduce1) Import the project
2) Run the sample
3) Resize the window
4) See that the text is now cut off
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.0.6.93
2.x Runtime Verified In9.9.1.1075

Activities

Fritz

2017-05-31 13:56

Manager   ~0053398

Unable to reproduce with runtime 9.9.1.588 believe this has been fixed already.

Stewart Bishop

2017-08-02 16:46

Developer   ~0054746

Still happens in the latest runtime, can show you when you get back onto the bug.

Russell Kay

2018-05-09 13:08

Manager   ~0059132

Unable to reproduce on v9.9.1.1019