View Issue Details

IDProjectCategoryView StatusLast Update
0026482RunnerWindows (YYC)Public2019-05-10 16:12
ReporterStewart BishopAssigned ToRussell Kay 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindows (YYC)OSOS Version
Product Version2.2.0 
Target Version2.2.3Fixed in Version2.2.3 
Summary0026482: Windows (YYC): Project results differ between VM and YYC
DescriptionUsing PerlinNoiseTest on VM you'll get some static, on YYC you'll just get a black screen

Using PerlinNoiseTest2 on VM you'll get a slow moving screen, on YYC your screen will move much faster but gain squares after a set amount of time.
Steps To Reproduce1) Import either
2) Compare VM and YYC
TagsNo tags attached.
1.4 Found In7.7.1451
2.x Runtime Found In
2.x Runtime Verified In9.9.1.1436

Activities

Stewart Bishop

2017-05-11 10:44

Adminstrator  

PerlinNoiseTest.gmz (10,671 bytes)
PerlinNoiseTest2.gmz (12,015 bytes)

Russell Kay

2017-05-18 16:46

Manager   ~0053232

Fixed in gitlab - return values were not being saved correctly....

Dan

2017-06-30 12:16

Adminstrator   ~0053982

Fix will be in EA550+.

Sam Cumming

2017-07-26 12:13

Developer   ~0054582

Replicated > 7.7.1540 - The first project still replicates a black screen on YYC, but the second project works fine and is fixed - Reopening.

Russell Kay

2017-07-28 11:30

Manager   ~0054661

The bug is in the code... as the FastNoise function returns an int64 value and that is divided by 256 to give a number from 0..1 (YYC is preserving the integer nature of this and gives 0 or 1, while VM version is being a bit more lenient and going the slower route) if you cast the return value to real() then it all works.

Russell Kay

2017-07-28 11:32

Manager   ~0054662

Not a bug.. but should be mentioned in documentation on differences between YYC and VM

Russell Kay

2019-01-29 17:10

Manager   ~0062562

Fixed in gitlab - http://yoyo-gitlab01.yoyogames.lan/runner/GameMaker/merge_requests/1154

long standing issue - but I managed to isolate what was wrong.
int64 + real addition was giving a type real on YYC but int64 on VM
YYC now resolves to an int64 now as well