View Issue Details

IDProjectCategoryView StatusLast Update
00263842.x IDE BugsBuild iOSPublic2021-07-22 11:07
ReporterDanAssigned ToCoreTech 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ResolvedResolutionSuspended 
PlatformiOSOSWindows 10OS VersionPro x64
Product VersionPre-2.1.3 
Target VersionFixed in Version 
Summary0026384: Build iOS: Runs can "succeed" according to log, despite the game not actually building in Xcode because of certificate issues
DescriptioniOS VM runs can "succeed" according to log, despite the game not actually building in Xcode because of certificate issues it is unable to fix automatically. Looks like we don't capture enough info from Xcode to detect that this has happened, and we simply treat Xcode telling us it has stopped the project as the end of the process.

Expected: The game is not running on your phone, so I would not expect to get a "Success" result.

(No, suppress build is not enabled.)

Steps To Reproduce1. Have a Mac which has certificate info, but no valid key attached to the certificate. Attach an iPhone to the Mac, and detect the phone in device manager.
2. Run a project for iOS VM after setting up game options correctly.
3. Observe the compiler log will appear as if all okay, but the game won't be running on your iPhone.

Repro: 100% (until I now fix my certificates)
TagsBuild, IDE, ios
2.x IDE Found In2.0.6.130
2.x Runtime Found In2.0.6.82
2.x IDE Verified In
2.x Runtime Verified In

Activities

Dan

2017-05-05 12:21

Adminstrator   ~0053012

Looks like the issue was that my Mac's keychain was stuck in that situation where Login has disappeared and you have Local Items instead - rebooted the Mac and ran again, and this time I could actually fix the issue within Xcode, but still by that point GMS2 had told me all was successful again.

SamH

2021-07-22 11:07

Developer   ~0066457

Unable to reproduce now. If this still happens in the current GMS2 release, then we will investigate a fresh report. Closing.