View Issue Details

IDProjectCategoryView StatusLast Update
00263162.0 IDE Bugs[2.x IDE Bugs] GeneralPublic2018-02-09 16:40
ReporterStewart BishopAssigned ToMike Dailly 
PriorityVery HighSeverityA - Crash/HangReproducibility100%
Status ResolvedResolutionNo Change Required 
Product Version 
Target VersionFixed in Version 
Summary0026316: General: File Dialogues can get stuck and never appear
DescriptionIn some rare cases if you open a file dialogue you can get it stuck, potentially as it's behind the window and you're never able to get it back. However with the recent white screen bug this is now a 100% repro bug as it seems to not work when your IDE is offline.
Steps To Reproduce1) Get the 45 Second white screen
2) New Project
3) GML
4) Dialogue never appears
2.x IDE Found In2.0.6.123
2.x Runtime Found In2.0.6.76
2.x IDE Verified In
2.x Runtime Verified In

Activities

Steven Campbell

2017-05-02 17:15

Developer   ~0052982

Possible fix in Red IDE GitHub Pull Request 3290
Git Ids: ad53b567d7e53e363faa9394c21ef571962e5d02 [ad53b567d7]

Daniel Cleaton

2017-05-11 14:10

Adminstrator   ~0053079

Still reproduces in 9.0.1.972. Reopening.

Steven Campbell

2017-05-15 15:45

Developer   ~0053110

After seeing it on Stewart's machine, the file dialogue doesn't even seem to appear.

Possible idea is that it's waiting on network drives, which is potentially linked to the 45 second white screen bug that is also lurking around.

Steven Campbell

2017-05-24 10:18

Developer   ~0053311

It's not even getting to the factory call to open the file dialogue window so adding even more debug information further up the chain to see where it's falling over...

Daniel Cleaton

2017-05-30 13:20

Adminstrator  

ui-dan.log (82,421 bytes)

Daniel Cleaton

2017-05-30 13:20

Adminstrator   ~0053381

Just got this. Attached my log.

Steven Campbell

2017-06-20 11:13

Developer   ~0053712

[15:38:33:351(5cae)] --------------------------------------------------------------------------------
[15:38:33:351(5cae)] Main Exception Handler: System.AccessViolationException
[15:38:33:351(5cae)] Exception message: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
[15:38:33:408(5cae)] Exception stack: at System.Windows.Forms.FileDialogNative.IFileDialog.Show(IntPtr parent)
   at System.Windows.Forms.FileDialog.RunDialogVista(IntPtr hWndOwner)
   at System.Windows.Forms.CommonDialog.ShowDialog(IWin32Window owner)
   at OpenTK.Platform.Windows.FileAPI.OpenFileDialog_Windows.ShowDialog(FileOpCompleteCallback _oncomplete, FileOpErrorCallback _onerror)
   at YoYoStudio.Plugins.MethodContainer.(Object[] )
   at YoYoStudio.Plugins.Command.execute_object(String _command, Object _focus, Object[] paramaters)
   at YoYoStudio.Plugins.CorePlugins.StartPage.StartPageModule.<>c.<SetupHomePage>b__59_0()
   at WeakDelegate(Object , Object[] )
   at YoYoStudio.Core.Utils.WeakDelegate`1.Invoke(Object[] _args)
   at YoYoStudio.Core.Utils.WeakEvent`1.Throw(InterruptEvent _interrupt, Object[] _args)
   at YoYoStudio.GUI.Gadgets.Button.ButtonClicked(Boolean _bRightClicked)
   at YoYoStudio.GUI.Gadgets.Button.ReleaseButton(Single _mousex, Single _mousey, eMouseButtons _buttons)
   at WeakDelegate(Object , Object[] )
   at YoYoStudio.Core.Utils.WeakDelegate`1.Invoke(Object[] _args)
   at YoYoStudio.Core.Utils.WeakEvent`1.Throw(InterruptEvent _interrupt, Object[] _args)
   at YoYoStudio.GUI.GUIBase.MouseUp(Single _mousex, Single _mousey, eMouseButtons _buttons)
   at YoYoStudio.GUI.WindowManager.DoActualMouseEvents(GUIBase _gadget, Int32 _mx, Int32 _my, eMouseButtons _currentState, eMouseButtons _eventState, Single _wheeldelta, Single _wheelvalue, Boolean _includeMouseOver)
   at YoYoStudio.GUI.WindowManager.ProcessMouse(Boolean _finalState, Int32 _mx, Int32 _my, eMouseButtons _currentState, eMouseButtons _eventState, Single _wheeldelta, Single _wheelvalue)
   at YoYoStudio.GUI.WindowManager.<HandleMouseEvents>b__62_0(MouseEventPacket _mouseevent)
   at YoYoStudio.Graphics.DesktopManager.ProcessMouseEvents(Action`1 _process)
   at YoYoStudio.GUI.WindowManager.HandleMouseEvents()
   at YoYoStudio.GUI.WindowManager.DoEvents()
   at YoYoStudio.IDE.Run()
   at YoYoStudio.IDE.Execute(String[] _args, Int32 _initialWidth, Int32 _initialHeight)
   at YoYoStudio.Program.Main(String[] _main_args)
[15:38:33:408(5cae)] --------------------------------------------------------------------------------

Daniel Cleaton

2017-06-21 09:31

Adminstrator   ~0053726

This *appears* to be an issue with Windows 10, likely since the Creator's Update. Reading around online, even MS Office apps have been seen to demonstrate the same issue.

Daniel Cleaton

2017-07-05 09:06

Adminstrator   ~0054039

We're still getting this, despite being on the latest (non-fast-ring) Win 10 version. Stewart saw this a lot yesterday. Unwilling to close right now, but have removed the 2.1 tag.

Steven Campbell

2017-08-16 11:19

Developer  

ui_crash-steven-win81.log (58,309 bytes)
ui-steven-win81.log (14,913 bytes)

Sam Cumming

2017-09-07 14:10

Adminstrator   ~0055352

Just got this again > 9.0.1.1170 /rt 9.9.1.713 - UI log attached.

Sam Cumming

2017-09-07 14:11

Adminstrator  

ui-sam.txt (455,214 bytes)

Mark Alexander

2017-09-18 10:29

Developer   ~0055541

Just had this on version 2.1.1.233 (runtime 2.1.1.145). Had a project open, saved it and then went to File > Recent and selected a different project from the recent list. The IDE went white , CPU usage went up to about 60% and I had to force close the IDE.

Mark Alexander

2017-09-18 10:30

Developer  

ui - Mark.log (77,608 bytes)

Sam Cumming

2017-09-25 12:09

Adminstrator   ~0055674

Every time I encounter this, it happens in batches. Usually three or four times in a row.

2.1.1.230 / rt 2.1.1.150

Mike Dailly

2017-09-25 14:00

Manager   ~0055677

We have now confirmed this is a windows issue. I've had this happen on a separate C++ program I was working on, exactly the same issue.

So it's definitely a windows 10 creators edition issue, and not something we can work around. This requires Microsoft to fix it.

Daniel Cleaton

2017-11-03 11:56

Adminstrator   ~0056428

We have submitted a bug report to Microsoft for this issue and will provide further info as requested so this can be resolved properly.