View Issue Details

IDProjectCategoryView StatusLast Update
0026267RunnerSpinePublic2019-01-30 12:09
ReporterStewart BishopAssigned ToMike Rennie 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product Version 
Target Version2.2.2Fixed in Version2.2.2 
Summary0026267: Spine: Skeleton Animations Transforms ALWAYS inherited by parent bones (even if specified otherwise)
DescriptionThis caused some problems with previously-working animations scaling in odd ways. Gamemaker no longer seems to be taking the "NoScale" attribute into account when playing skeleton animations.

EXAMPLE:
{ "name": "LeftBone", "parent": "Ballbone", "length": 124.43, "rotation": -90, "x": -31.2, "y": 0.41, "transform": "noScale" },

The included materials should explain the problem very clearly. The zip file includes:
-Project GMZ
-Spine Project
-Spine Skeleton JSON/Image Export
-GIF of how animation looks in Spine
-GIF of how animation looks in GameMaker
-Screenshots of Spine Settings
Steps To Reproduce1) Run the sample
2) See that it's not as it is shown in Spine
TagsRunner, Spine
1.4 Found In1.99.533
2.x Runtime Found In
2.x Runtime Verified In2.2.2.302

Activities

Stewart Bishop

2017-04-21 10:34

Adminstrator  

SpineAnimationBUG-1.99.525.zip (981,650 bytes)