View Issue Details

IDProjectCategoryView StatusLast Update
0026028RunnerSurfacesPublic2017-08-08 10:34
ReporterEric BuneseAssigned ToFritz 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10OS Version
Product Version 
Target VersionFixed in Version 
Summary0026028: surface_save causes a memory leak for each call
DescriptionCreate a surface, and whenever you use surface_save, the memory usage will go up a little bit. Potentially crashing the game due to lack of memory.
Steps To Reproducesurface_create
repeat(X)
    surface_save
surface_free
1.4 Found In1.4.1763
2.x Runtime Found In2.0.5.
2.x Runtime Verified In

Activities

Eric Bunese

2017-03-24 19:11

Updater  

Project1.gmz (8,535 bytes)
Screenshot_2.png (53,093 bytes)
Screenshot_2.png (53,093 bytes)

Eric Bunese

2017-03-24 19:20

Updater   ~0052476

Precisely the same behaviour if we use sprite_save from a sprite created from the surface as following:

 var spr = sprite_create_from_surface(surf, 0, 0, 1024, 768, 0, 0, 0, 0);
 sprite_save(spr, 0, "bla.png")
 sprite_delete(spr)

The surface must be copied at some point to create these functions and it is not freed.

Fritz

2017-03-28 14:06

Developer   ~0052513

Not reproducing in Red, believe Russ has fixed this.