View Issue Details

IDProjectCategoryView StatusLast Update
0025833Runner3DPublic2017-03-06 10:49
ReporterDaniel CleatonAssigned ToMike Rennie 
PriorityVery HighSeverityA - Crash/HangReproducibility100%
Status ClosedResolutionFixed 
Platform-OSWindows 8OS Version8.1 Pro x64
Product Version 
Target VersionFixed in Version 
Summary0025833: Spine: Downloading sprites via sprite_add() and setting these as attachments will crash the runner
DescriptionDownloading sprites via sprite_add() and setting these as attachments will crash the runner. Using sprite_add() on a file already in the project at compile time and then setting this as the attachment is fine, so the issue is with downloaded files.
Steps To Reproduce1. Run the attached sample on Windows.
2. Press spacebar when told to.
3. Observe the runner immediately crashes.

Repro: 100%
1.4 Found In1.99.525
2.x Runtime Found In
2.x Runtime Verified In

Activities

Daniel Cleaton

2017-03-02 14:01

Adminstrator  

spine_crash.gmx.zip (1,625,623 bytes)

Mike Rennie

2017-03-02 14:13

Developer   ~0051891

Actually, I found that it also crashed even if I called sprite_add() on an included file. Either way, both of these problems have been fixed.

Fix is in commit d398835 in gitlab.

Daniel Cleaton

2017-03-06 10:48

Adminstrator   ~0052035

https://yoyogames.zendesk.com/agent/tickets/119904 is the same, but using an Included File. Now works since this fix.

Daniel Cleaton

2017-03-06 10:49

Adminstrator   ~0052036

Works fine in EA530. Closing.