View Issue Details

IDProjectCategoryView StatusLast Update
00256602.x IDE BugsRoom EditorPublic2021-07-19 10:56
ReporterMark AlexanderAssigned ToCoreTech 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ResolvedResolutionSuspended 
Product Version 
Target VersionFixed in Version 
Summary0025660: Room Editor: offsets backgrounds by offsetting the entire layer and not just the element
DescriptionOkay, so, in CODE, layers can have multiple different elements, and each element can be positioned anywhere... except background elements (I've addressed this in another bug report). BUT in the room editor, the background layers have an X/Y offset value. The problem here is that this value doesn't actually offset the background ELEMENT but offsets the whole layer it is on. When working just with the room editor, that's fine, but the moment you want to add anything through code to the same layer that the background element is on, then you have issues, as the layer is not where it should be since it's been offset in the room editor.

So, the room editor should offset the background element when you change the offset values and not the whole layer itself.
TagsIDE, RoomEditor
2.x IDE Found In9.0.1.777
2.x Runtime Found In
2.x IDE Verified In
2.x Runtime Verified In

Activities

There are no notes attached to this issue.