View Issue Details

IDProjectCategoryView StatusLast Update
0025506RunnerGeneralPublic2018-10-29 14:45
ReporterStewart BishopAssigned ToMike Rennie 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSOS Version
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0025506: General: No support for G-Sync/FreeSync within the runner, causes game FPS to be inconsistent
DescriptionWithin the runner we have no support for G-Sync or FreeSync which causes your FPS to be inconsistent.

At the default sleep timer of 1ms your game will run at 25 FPS when you've set it to 60 FPS within game options which is not ideal, changing the sleep timer to 10ms causes your FPS to double to roughly 50 but then jumps constantly between 50 and 60 so your gameplay isn't smooth.
Steps To Reproduce1) Get a monitor with G-Sync and a GPU which supports G-Sync
2) Enable G-Sync in the NVIDIA Control Panel
3) Create a project
4) Set FPS in game options to 60
5) Show your FPS somewhere
6) Run your project
7) See that your FPS is not 60
8) Turn off G-Sync in the NVIDIA Control Panel
9) Run your game again
10) See that your FPS is now constantly 60
Tagsrendering, Runner, Windows
1.4 Found In9.0.1.722
2.x Runtime Found In
2.x Runtime Verified In2.2.1.268

Relationships

duplicate of 0029146 ClosedMike Rennie General: FPS is consistently wrong across platforms when using a high refresh rate monitor 

Activities

Dan

2017-03-10 12:23

Adminstrator   ~0052132

Reports that GMS1 games can even run more smoothly when OUT-of-focus on G-Sync monitors.

Dan

2018-10-29 11:59

Adminstrator   ~0061883

Should be fixed as part of 0029146.

Note that we do not recommend a sleep margin other than 10, so issues might still be seen on some machines when running at 1.