View Issue Details

IDProjectCategoryView StatusLast Update
0025185RunnerFontPublic2018-10-25 16:02
ReporterzenAssigned ToClaire Hall 
PriorityVery LowSeverityD - MinorReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOS OS Version
Product Version2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0025185: Windows: [GMS2] Using the Belmongo font with draw_text(), the "s" and "q" will appear stange
DescriptionBelmongo Font (a opentype font). When i use the Belmongo font, the "s" and "q" will appear stange text point. but it seems like no problem in the font editor.
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/118408
TagsNo tags attached.
1.4 Found In
2.x Runtime Found In2.0.3.56
2.x Runtime Verified In2.2.1.268

Activities

Alexander Borup

2017-02-01 11:49

Developer   ~0051395

I've added support for OpenType fonts in GMS2. Given that we had no support for these when this bug was reported (in GMS2), I am going to make "an educated guess" and say the user is talking about GMS1 ;)

YellowAfterlife

2017-02-03 05:24

Developer   ~0051431

Alexander, that hints towards higher mysteries, as Sample URL links to a YYZ.

Dan

2018-06-01 14:30

Adminstrator  

bug1.yyz (18,580 bytes)

Claire Hall

2018-06-20 12:23

Developer   ~0060502

The project doesn't include the source font file to test with, but with a version of Belmongo I found on the internet after regenerating the font texture the font renders normally.

Adding a git sha since it was tested in a local version post other font rendering changes but may already be fixed in latest green

IDE - 60ebd63dd70004df7d3acfc93d14d9e31124127d
Runtime - cbdd82a587919daa0c630d9264412a84c1a3235e

Dan

2018-09-28 11:31

Adminstrator   ~0061662

As per the comment above, this *might* be fixed already in 2.1.5/2.2.0, but to be safe I have set this as fixed in 2.2.1.