View Issue Details

IDProjectCategoryView StatusLast Update
00251262.x IDE BugsDevice ManagerPublic2018-10-29 12:18
ReporterMark AlexanderAssigned ToClaire Hall 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0025126: Device Manager: Microsoft Edge cannot be added (except as the Default device)
DescriptionWhile trying to get the HTML5 target to use the Win 10 Edge browser I just couldn't get it to work. From what I can find online just running the exe doesn't work (from the location: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\MicrosoftEdge.exe) and you need to have it pinned to the taskbar since it is a Universal App... No matter what you do, you can't get GMS to actually run it UNLESS it is set in the OS as the default browser and you have first cleared the target device list and restarted GMS2.

So, I'm filing a bug to see if there is any way that we can get it to be detected and run using the device manager other than having it set as the default browser.
TagsIDE, preferences, TargetManager
2.x IDE Found In9.0.1.655
2.x Runtime Found In
2.x IDE Verified In2.2.1.355
2.x Runtime Verified In2.2.1.268

Activities

Russell Kay

2018-06-16 11:18

Manager   ~0060429

I doubt this is something we can add (unless MS have added something that allows Edge to be started from the command line)

actually after a bit of browsing looks like we can use https://edgetalk.net/how-to-launch-microsoft-edge-from-run-or-command-prompt/, so should be possible now

Claire Hall

2018-08-13 12:06

Developer   ~0061194

runtime: d5fa4312976eebf6ee62b1268d7e54be07706769