View Issue Details

IDProjectCategoryView StatusLast Update
0025012Runner[All Projects] GeneralPublic2020-03-09 15:36
ReporterMark AlexanderAssigned ToFritz 
PriorityLowSeverityD - MinorReproducibility100%
Status ClosedResolutionWon't Fix 
Product Version 
Target VersionFixed in Version2.3.0 
Summary0025012: Functions: Fix path_get_time() to be useful
DescriptionI was tasked with documenting the function "path_get_time" the other day and on investigation I could find no way to get this function to work how I assumed. Namely, that you supply a path and a speed, and the function will return how long it will take to traverse the path at the constant speed given.

Now, on testing, I was getting weird values returned that did not correlate to the time taken to traverse the path in any way, so I asked about it and was informed that it simply returns the path length multiplied by the speed given. This makes little sense to me, and I can't really work out how that correlates to time.

So, I would say that the the function is broken and should be fixed to do just what it appears it should do, ie:

The function will return the time it takes to travel the path from start to finish given a constant speed (based on the current room speed).
TagsFuntions, Runner
1.4 Found In
2.x Runtime Found In
2.x Runtime Verified In9.9.1.1717

Relationships

related to 0025001 ResolvedMark Alexander Documentation No manual entry for path_get_time() 

Activities

Russell Kay

2018-05-02 16:37

Manager   ~0058966

I think this is moot since the function is not in the documentation at the moment - but the number is a bit dubious - though this is how GM8 did it

Fritz

2020-01-23 10:30

Manager   ~0065321

I've removed the path_get_time function as it wasn't documented, didn't work had no html5 implementation and would require a large amount of work in order to return the correct results

Scott Dunbar

2020-03-09 15:36

Adminstrator   ~0065479

Verified function has been removed IDE v9.2.1.2152 Runtime v9.9.1.1717