View Issue Details

IDProjectCategoryView StatusLast Update
0024977RunnerAndroidPublic2018-10-29 13:14
ReporterScyllaAssigned ToFritz 
PriorityHighSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
PlatformAndroidOSOS Version
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0024977: Android: Current surface/shader breaks after returning from OS being paused
DescriptionI have a shader: shd_overlay.

It's meant to act as a Photoshop Overlay filter so I can overlay a nice blue tint across my screen. To do this I use a surface and fill it in via a rectangle set to the color of the tint.

I then set the stage to the texture of this surface after setting the shader, draw the application_surface, and then I reset the shader.

It works great. However, when I press the 'Home' button or the 'Recent Apps' button and then return to the game, the surface/shader seems to have broken. I'm going to assume it's the surface.

I then attempt to re-create the surface after I've returned back to the game. This does not work. The only way to return the surface/shader back to normal is to reset the game, which is clearly not a viable option.
Steps To ReproduceRun the sample .gmz provided on any Android device.

The screen tint is blue. This is how it should look.

Click on the 'Home' button or the 'Recent Apps' button on your Android device, and then return to the game.

The blue tint is now gone and the surface is clearly broken in some way. You can attempt to fix it by resetting the surface / shader stage using the red button, but it will not work.

Click the green reset game button and you will notice the shader is now back to normal.
Additional InformationTested on both GMS EA v1.99.505 and GMS

Tested on a Nexus 4 Phone and Nexus 7 (2012) Tablet.

After resetting the game, you can also notice the surface breaks the same way if instead of pressing the 'Home' / 'Recent Apps' button, you just press the red 'Tap To Recreate Surface/Shader' button.

No idea what's going on. This works perfectly fine on Windows 10, but not Android.

Included is the sample .gmz file and also a screenshot to show what the shader looks like when enabled, disabled, and when broken.
Tagsandroid, rendering, Runner
1.4 Found In1.4.1763
2.x Runtime Found In
2.x Runtime Verified In2.2.1.268

Activities

Scylla

2016-12-17 07:44

Updater  

ShaderAndroidTest.gmz (66,441 bytes)
together.jpg (150,868 bytes)
together.jpg (150,868 bytes)

Fritz

2018-08-15 14:27

Manager   ~0061257

on resume didn't seem to be causing an issue any more, but this fixes the button press which was.