View Issue Details

IDProjectCategoryView StatusLast Update
00247442.x IDE BugsUIPublic2019-04-23 16:57
ReporterRoss ManthorpAssigned ToSteven Campbell 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10OS VersionWindows 10
Product Version 
Target VersionFixed in Version2.2.0 
Summary0024744: UI: Windows 10 multiple desktop focus switching (crazy flickering)
DescriptionIf a second IDE window is spawned and then moved to a second Windows 10 virtual desktop when moving to this second desktop the screen will flicker as the focus rapidly changes - before it gives us and returns to the first desktop...
Steps To Reproduce1. Open the IDE
2. Help -> Welcome Page
3. Pull out Welcome Page to a new IDE window
4. Create a new Windows 10 desktop and move this IDE window to the new desktop
5. Navigate to the new desktop
6. See flicker and return to the current desktop
Additional InformationSerious flashing warning on this one FYI
TagsIDE, rendering, UI
2.x IDE Found In2.0.2.44
2.x Runtime Found In9.9.1.
2.x IDE Verified In
2.x Runtime Verified In

Activities

Claire Hall

2016-12-22 14:53

Developer   ~0050785

probably related to DesktopManager.BringDesktopsToFront which is called when a desktop gets focus to try and bring all ide windows to the front of other non-ide windows.

On windows 10 if the other 'ide desktop' window isn't on the same 'windows os desktop' as the window that gained focus then we shouldn't try to bring it to the front

see -

GetWindowDesktopId - https://msdn.microsoft.com/en-us/library/windows/desktop/mt186441(v=vs.85).aspx

IsWindowOnCurrentVirtualDesktop - https://msdn.microsoft.com/en-us/library/windows/desktop/mt186442(v=vs.85).aspx

Steven Campbell

2019-04-23 12:16

Manager   ~0063679

This was actually "fixed" by Chris as he removed the offending code due to issues on Mac.
To quote:
"Remove code that forces all other desktops to the front on a desktop gaining focus then re-focuses the desktop that was triggering the focus event as it:
    a) Seems unnecessary.
    b) Relies on a hack that doesn’t always work on Mac."

Dan

2019-04-23 16:57

Adminstrator   ~0063696

That was April 2017, so this has been out in public releases for a long time (quite a bit before 2.2.0, but that's the oldest version I can pick now). Closing.