View Issue Details

IDProjectCategoryView StatusLast Update
00247352.x IDE BugsBuild MacPublic2021-07-16 14:05
ReporterDanAssigned ToCoreTech 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
Platform-OSWindows 8OS Version8.1 Pro x64
Product Version 
Target VersionFixed in Version 
Summary0024735: Build Mac: Some parts of the projects we create require the OS deployment target to be 10.12, otherwise 200+ build warnings
DescriptionThere are two components we include, which Xcode shows many warnings about them being built with a newer target OS than what the project is set to by default. The warnings will persist for all versions of OSX other than 10.12.

We need to see if these two extensions can be re-built using a lower target OS, otherwise we will need to advise a rise in the minimum-supported OSX version for builds.
Steps To Reproduce1. Start the IDE and open/create any project.
2. Run it for macOS.
3. Observe the Xcode project shows a blank value or 10.6 for the minimum target OS (#0024717) dropdown halfway-ish down the screen.
4. Observe also you will have 20+ build warnings in the column to the left, all of which say you need to target 10.12.
5. Change the minimum OS version to be 10.12 and wait a few seconds. Observe warnings go.

Repro: 100%
Tagsmac, Runner, xcode
2.x IDE Found In2.0.2.44
2.x Runtime Found In2.0.1.27
2.x IDE Verified In
2.x Runtime Verified In

Activities

Dan

2021-07-16 14:05

Adminstrator   ~0066364

Has been fixed or made invalid by changes in recent versions of GMS2. Closing.