View Issue Details

IDProjectCategoryView StatusLast Update
0023698RunnerMacPublic2018-10-29 09:57
ReporterYellowAfterlifeAssigned ToMike Rennie 
PriorityLowSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformMacOSOS Version8.1
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0023698: Mac: d3d mode shows no signs of depth buffer
DescriptionI wanted to compile my jam game for OSX but turns out that it acts as if it does not have a depth buffer on OSX. Device is a standard issue Mac Mini with Intel HD Graphics 5000.

Is working fine on Windows and Linux on a device with Intel HD Graphics 5600.
TagsNo tags attached.
1.4 Found In1.4.1757
2.x Runtime Found In
2.x Runtime Verified In2.2.1.268

Activities

YellowAfterlife

2016-09-18 02:29

Developer  

16-09-19-1-osx.png (440,791 bytes)
16-09-19-1-win.png (22,832 bytes)
16-09-19-1-win.png (22,832 bytes)
osx-depth.gmz (18,063 bytes)

YellowAfterlife

2016-09-18 02:30

Developer  

16-09-19-1-osx-.png (37,081 bytes)
16-09-19-1-osx-.png (37,081 bytes)

Russell Kay

2018-05-04 16:08

Manager   ~0059093

Here is a GMS2 issue - but still a problem

osx-depth.yyz (73,066 bytes)

Mike Rennie

2018-09-13 09:41

Developer   ~0061573

This previously worked fine if you didn't disable the application surface (like the sample did) but now it works when the application surface is disabled too.