View Issue Details

IDProjectCategoryView StatusLast Update
0023291Runner[All Projects] FunctionsPublic2018-06-28 10:09
ReporterlorefoldAssigned ToRussell Kay 
PriorityNoneSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOS OS Version
Product Version 
Target VersionFixed in Version2.1.5 
Summary0023291: Functions: Every 16th entry in a ds_queue becomes undefined until a 17th entry is added
DescriptionWhen using a ds_queue every 16th element in the queue is undefined until a 17th element is entered.

Using the sample provided this will show this off, it will crash when reaching the 16th element and if you comment out line 14 in the draw event of the object you'll see that this is due to the values being undefined.
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/109813
TagsNo tags attached.
1.4 Found In1.99.503
2.x Runtime Found In
2.x Runtime Verified In

Relationships

has duplicate 0028554 ClosedChris Harrison Functions: Copying a ds_queue using ds_queue_copy(id, source) with 16 elements makes the last element in the destination queue 0 

Activities

Stewart Bishop

2016-08-23 09:25

Adminstrator  

invalidtype.gmz (9,489 bytes)

Russell Kay

2018-05-16 15:33

Manager   ~0059750

Fixed in gitlab