View Issue Details

IDProjectCategoryView StatusLast Update
0020080DocumentationManual ContentPublic2018-11-15 17:31
ReporterLeifAssigned ToMark Alexander 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformOSWindows 8OS Version
Product VersionPre-2.1.3 
Target Version2.2.0Fixed in Version2.2.0 
Summary0020080: Manual Content: font_add() incorrectly says "if WebGL is enabled then you must use an included font file"
DescriptionWhen using an OpenType font within font_add it doesn't change the font or alter the pixel size on the HTML5 target however when used on the Windows target it will work as expected.

Attached is a sample which has an .otf included that is used as an argument for font_add and you'll notice that the font is correct as well as the expected size on the Windows target but on HTML5 it is tiny and looks like Arial regardless of the pixel size provided.
Steps To Reproduce1) Run the sample on Windows target to see the expected result
2) Run the sample on HTML5 to see the above bug
3) Within object0 change the size from 32 to 128
4) Run this on HTML5 to see that it has not changed
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/99585
Tagshtml5, Runner

Activities

Stewart Bishop

2016-01-18 17:16

Adminstrator  

Font_Add.gmz (173,476 bytes)

Alan Savage

2018-07-30 12:29

Developer   ~0060965

included ttf/otf fonts are not currently supported on html5 target, only WebFonts as described in documentation for "font_add"; however documentation for "font_add" could be clearer as it currently has the line "if WebGL is enabled then you must use an included font file"

Mark Alexander

2018-07-31 11:16

Developer   ~0060982

Fixed. Manual has been updated to clarify.

Dan

2018-09-27 14:49

Adminstrator   ~0061633

2.2.0 now says "For the HTML5 target module, this function can only be used to add Web Fonts, and will only work if WebGL is not enabled - if WebGL is enabled then you must use a general font resource (ie: using draw_set_font along with a font from the resource tree) or bitmap fonts (see font_add_sprite)."

Closing.