View Issue Details

IDProjectCategoryView StatusLast Update
00191422.1 IDE Bugs [2.x IDE Bugs] Code EditorPublic2018-05-09 13:17
ReporterStewart BishopAssigned ToAlan Savage 
PriorityLowSeveritySuggestionReproducibilityN/A
Status ClosedResolutionDuplicate 
PlatformOSWindowsOS Version
Product Version 
Fixed in Version 
Summary0019142: Suggestion: Code Editor: Shift + Tab should decrease the indent at the cursor position
DescriptionShift + Tab has differing behaviour depending on which code editor you are using:

Visual Studio will decrease the indent from where the cursor currently is.
Notepad++ will decrease the cursor for the indent size but not actually remove any text
Sublime will remove the white space at the start of the line if unindent is not enabled in the options

Our code editor trims the white space at the start of the line even if there is a valid amount of text selected which could be unindented.

I'd like it so we go with how Visual Studio does the behaviour of Shift + Tab or at least provide an option like Sublime does in that you can have it so the behaviour to be either trim the white space or unindent depending on your preference or both depending on if you have text selected and there are no indents on that line.
Steps To Reproduce1) Enable white space in the code editor preferences
2) Create a script
3) Add an indent to the start of a line
4) Type some text, adding tabs in between
5) Press Shift + Tab to see that it will trim the white space
6) Undo the above action and select an intend and press Shift + Tab and see that it will also trim the white space rather than the selected indent
2.x IDE Found In
2.x Runtime Found In
2.x IDE Verified In0.0.
2.x Runtime Verified In

Relationships

duplicate of 0028067 ResolvedAlan Savage Code Editor: Shift + Tab behaviour is not as expected compared to Visual Studio 
has duplicate 0028795 ResolvedAlan Savage Code Editor: Unindent at caret, not whole line 

Activities

Daniel Cleaton

2017-11-17 10:20

Adminstrator   ~0056675

Last edited: 2017-11-24 11:17

View 2 revisions

Still the case in current red / 2.1.3.

Daniel Cleaton

2018-05-09 13:17

Adminstrator   ~0059138

Agreed. Closing.