View Issue Details

IDProjectCategoryView StatusLast Update
00190061.4 IDE BugsBuild UbuntuPublic2018-02-14 11:16
ReporterBPzeBansheeAssigned ToAlan Savage 
PriorityVery LowSeverityC - GeneralReproducibility100%
Status AssignedResolutionOpen 
PlatformUbuntuOS OS Version
Summary0019006: Build Ubuntu: .deb export gives "This package is of bad quality" when attempting to install
DescriptionNo matter what I do on the Linux Preferences page or Global Game Settings for my project I end up with a .deb file in Home/GameMaker-Studio that Ubuntu Software Center claims is of bad quality when attempting to use it for installing purposes.

Initially I started with a game project (which otherwise compiles/plays fine) for testing these issues, but as demonstrated below a new project file with a blank room will also give the same issues. Using a blank project without any modifications (aside from adding an email address in Global Game Settings>Linux where expected) leads to this error:
"Lintian check results for /home/bp/GameMaker-Studio/Project1.deb:
E: Project1: bad-package-name

E: Project1: package-not-lowercase

E: Project1: maintainer-name-missing admin@project1.com

Use of uninitialized value $name in pattern match (m//) at /usr/share/perl5/Lintian/Check.pm line 214."

I then figured out to get around the maintainer-name-missing and $name error to change the given email address into a name and email address in the format (with quotation marks) 'Name <admin@yolo.com>'. The Debian Policy Manual helped a little here but I continued to have issues until I put the ' marks around it.

Furthermore, the only way I was able to get around the package-not-lowercase error was by renaming the .project.gmx file to be lowercase which seems a bit ridiculous to me. Changing the name listed in Global Game Settings made no difference here.

Finally, after all that I still get the error because apparently GMS is not providing amongst several other things that the Software Center has "not available" marked on, the Installed-Size field variable. To be precise I get this error:
"The package doesn't provide a valid Installed-Size control field. See Debian Policy 5.6.20." SAMPLE URL:
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/94865
1.4 Found In1.4.1657

Relationships

duplicate of 0028888 AssignedAlan Savage Build Ubuntu: Debian exports fail to install correctly 

Activities

There are no notes attached to this issue.