View Issue Details

IDProjectCategoryView StatusLast Update
0018937RunnerSpinePublic2019-01-30 13:55
ReporterJaimeAssigned ToMike Rennie 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
Platform OS OS Version
Product Version 
Target Version2.2.2Fixed in Version2.2.2 
Summary0018937: Spine: Animations don't switch when there is only 1 keyframe in 0 position.
DescriptionI am unable to switch animations when the animations have only 1 keyframe in the 0 position timeline, the function "skeleton_animation_set" does not work..

If i put 2 keyframe(one in 0 position and one in 1 position), the problem is solved, but is very importante for this proyect to have only one keyframe in the 0 position in each animations. Thanks in advance.
Steps To Reproduce1) Run the sample project
2) Press W or Q to rotate through the animations
3) Notice the animations won't change
4) Open the .spine file in the included files
5) See that each "animation" has 1 frame per animation and when changing the animation the sprite changes too
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/90937
TagsRunner, Spine
1.4 Found In1.4.1657
2.x Runtime Found In
2.x Runtime Verified In2.2.2.302

Activities

Stewart Bishop

2015-09-21 10:27

Developer  

Switch_animation_bug.gmz (271,361 bytes)