View Issue Details

IDProjectCategoryView StatusLast Update
0018918RunnerHTML5Public2019-01-30 17:45
ReporterChristian JaegerAssigned ToMike Rennie 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OS OS Version
Product Version 
Target Version2.2.2Fixed in Version2.2.2 
Summary0018918: HTML5: Spine IKs aren't working, results in the whole Mesh collapsing
DescriptionExporting a html5 Game with Spine Animations with IK constrains results in the whole Mesh collapsing. It works fine as a Windows export or without IK`s.

Links to GIF`s:

With IK`s:
http://i.imgur.com/eTfjiUu.gif?1

Without IK`s
http://i.imgur.com/h9JYZ11.gif?1
Steps To Reproduce1) Run the test project on Windows to see the intended result
2) Run the test project on HTML5 to see the difference
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/90767
Tagshtml5, Runner, Spine
1.4 Found In1.4.1629
2.x Runtime Found In
2.x Runtime Verified In2.2.2.302

Activities

Stewart Bishop

2015-09-11 15:08

Developer  

test_Iks.gmz (446,041 bytes)

Mike Dailly

2018-07-30 14:43

Developer   ~0060969

No longer works on windows. I suspect the spine file is now too old, so we'd need a new test.

Mike Dailly

2018-07-30 15:44

Developer   ~0060972

reopening - can patch the file spine apparently.

Mike Rennie

2018-11-02 10:42

Developer   ~0061936

Attaching project ported to GMS2 with patched spine files (needed to replace instances of "skinnedmesh" with "mesh" in the JSON files)

bug_18918_test_Iks.yyz (218,660 bytes)

Mike Rennie

2018-11-02 10:43

Developer   ~0061937

This appears to have already been fixed.