View Issue Details

IDProjectCategoryView StatusLast Update
0018829RunnerHTML5Public2018-02-06 11:43
ReporterkyzcreigAssigned ToMike Dailly 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformHTML5OS OS Version
Product Version 
Target VersionFixed in Version 
Summary0018829: HTML5: Blue and red are swapped for the sprite functions that use color blending [if using swf]
Descriptionblue and red are swapped in HTML5 for the sprite functions that use color blending.

meaning, if you draw a sprite with the color blend parameter set to blue, it will come out red and vice versa. HTML5 only.

tested on various browsers, including chrome.
Steps To Reproduce1) Run the attached project in HTML5 and see that the colors are swapped.
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/90275
1.4 Found In1.4.1634
2.x Runtime Found In
2.x Runtime Verified In

Activities

Stewart Bishop

2015-08-27 14:08

Adminstrator  

HTML5_SWF_Red_Blue_Flipped.gmz (8,823 bytes)

GameGeisha

2015-11-08 05:43

Updater   ~0040322

Still happening on 1.4.1657.

On HTML5, the squares come out red-green-blue as expected, but the circles come out blue-green-red. This bug seems to be triggered only for sprites with transparent regions.

Mike Dailly

2017-11-09 16:52

Manager   ~0056519

This should be fixed