View Issue Details

IDProjectCategoryView StatusLast Update
0016962RunnerFunctionsPublic2021-07-23 15:39
ReporterOndrej SikyrAssigned ToCoreTech 
PriorityLowSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
PlatformWindowsOSWindows 7OS Version
Product Version 
Target VersionFixed in Version 
Summary0016962: Functions: keyboard_string doesn't render Non Latin characters
DescriptionI have a problem, I can´t write characters č/Č, ď/Ď and ě/Ě, even though they are listed in the font.
Other characters seem to work as they should (but i´m not absolutely sure). I tried several possible fonts, but always with the same result.

Also, another problem occurs when I try to copy some text with some czech characters to the clipboard,
for example, if I write in GM (through keyboard_string) "řež" and try to copy that to the clipboard, and paste that for example to the notepad, I get this "衲řeĹľ", which is really strange.
Additional InformationOriginal helpdesk ticket:
TagsRunner, Windows
1.4 Found In1.4.1773
2.x Runtime Found In
2.x Runtime Verified In


Neil Wicker

2015-01-23 11:28

Updater   ~0035352

Do you have a sample that reproduces this issue? or at least a link to the font that you are using?


2015-01-23 18:51

Updater   ~0035383

Czech characters draw just fine on 1.4.1499, see the uploaded sample. It looks like another case of not including the right characters.


2015-01-23 18:51


CzechChars.gmz (1,170,269 bytes)


2015-01-26 15:24

Reporter   ~0035414

Last edited: 2015-01-26 15:48

View 2 revisions

Actually the problem is not caused by the fonts at all, the problem is in the keyboard_string that does not work properly. (added new example CzechChars2.gmz)


2015-01-26 15:25


CzechChars2.gmz (1,346,842 bytes)

Neil Wicker

2015-01-26 15:56

Updater   ~0035415

CzechChars2.gmz seems to work as I would expect. All the characters are displayed correctly, on start up and when copying and pasting. Can you describe the issue some more?


2015-01-26 16:08

Reporter   ~0035416

Yeah, the problem is when you try to type them by the keyboard.


2015-01-26 16:10

Reporter   ~0035417

And also when you try to copy some text from elsewhere (from another application or so).

Neil Wicker

2015-01-26 16:57

Updater   ~0035421

yeah okay, I see the issue now. Assigned.

Russell Kay

2018-06-15 12:08

Manager   ~0060383

I have done a bit of investigation on this and for č Lowercase c with caron Alt + 0269, then Windows is actually sending the character 13 to WM_CHAR.

The documentation held out some hope with WM_UNICHAR but I am not receiving that message at all from Windows (on WIndows 10) no matter what is typed... some confusing documentation on that.

I cannot get Windows to send me that character code at all - not sure what is happening there.


2021-07-23 15:39

Developer   ~0066495

No longer reproduces in v2.3.3. Closing.