View Issue Details

IDProjectCategoryView StatusLast Update
0016877Runner3DPublic2018-05-09 16:29
ReporterAlexanderAssigned ToRussell Kay 
PriorityVery LowSeverityC - GeneralReproducibility100%
Status ClosedResolutionWon't Fix 
PlatformWindowsOS OS Version
Product Version 
Target VersionFixed in Version 
Summary0016877: 3D: Drawing primitives overfills vertex buffer
Descriptionhello,

for creating a complex-background graphic on a surface, I've encountered into an issue with GM:Studio.
Apparently every primitive I draw in a single step, no matter whether onto the screen or onto a custom surface, is loaded into the "vertex buffer".
For creating the background, I require many thousands of polygons what causes the following error:
[quote]
Fatal Error: Can not create vertex buffer of size 98304 bytes
9467 vertex buffers allocated with total size of 956192 KB
[/quote]

Would be great if there would be a function to flush the vertex buffer manually.

By the way: The exact code worked perfectly fine in GM 8.1! There I can even draw millions of polygons.
Isn't it possible to allow that in Game Maker Studio as well?

I've also tried the GM:S way of drawing primitives via the functions vertex_create_buffer(), vertex_begin, ... and vertex_delete_buffer(buff).
But it resulted in exactly the same error message although the vertex-buffer was clearly deleted.

Hope this can be solved!
If it helps: The issue appears on a Surface Pro 2 with an integrated graphics.
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/77349
TagsNo tags attached.
1.4 Found In1.4.1470
2.x Runtime Found In
2.x Runtime Verified In

Activities

Neil Wicker

2014-12-17 12:27

Updater   ~0034803

Assigning for future reference.

From the ticket:

Technically it is not a bug (he has created a primitive buffer that is too big) but we could possibly handle this better (please direct to Mike Rennie... we may yet decide to do nothing with it though)

Russell

Russell Kay

2018-05-03 21:24

Manager   ~0059046

this was a user problem (see the comments)

Dan

2018-05-09 15:28

Adminstrator   ~0059224

Agreed. Closing.