View Issue Details

IDProjectCategoryView StatusLast Update
0015806Runner3DPublic2019-05-13 17:15
ReporterrcusumanoAssigned ToMike Dailly 
PriorityVery LowSeverityD - MinorReproducibility100%
Status ClosedResolutionFixed 
Product VersionPre-2.1.3 
Target Version2.2.1Fixed in Version2.2.1 
Summary0015806: 3D: Building a primitive using incomplete vertex functions is inconsistent across Windows and HTML5
DescriptionBuilding a primitive using incomplete vertex functions is inconsistent accross Windows and HTML5.

→ On Windows, unmentioned parameters like color and alpha are added from global draw settings at draw-time.
→ On HTML5, such parameters are precompiled into the model from global draw settings.

I have been told the expected behavior is what happens on HTML5: it precompiles missing parameters from global settings. However, traditionally GameMaker behaved as it is on Windows right now, and this difference is not mentioned in the manual or it is a bug on Windows runner technology.
Steps To Reproduce→ create a model
→ set global draw settings with draw_set_color and alpha
→ add a primitive to the model using incomplete vertex functions

on draw event,

→ set different global draw settings
→ draw model.

On Windows, model will assume new settings. On HTML5, it will correctly maintain the settings used while building it.
Additional InformationI was going to add the project I'm working on, but will have to do that later because I can't get the model to display on HTML5 right now. I will add the project file when it's working.
Tagsrendering, Runner
1.4 Found In1.4.1398
2.x Runtime Found In
2.x Runtime Verified In9.9.1.1437

Activities

Lewis Crawford

2014-08-25 14:59

Updater  

IncompleteVertexModelExample.gmz (926,199 bytes)

Lewis Crawford

2014-08-25 15:07

Updater   ~0032150

Uploaded an example file.

Note that it seems like HTML5 the model actually takes on the colour and alpha from the global draw settings for the first time it is drawn (not when it is created as the bug report suggests). On Windows, it takes on the current global draw settings (so if these differ from the first draw, windows will update but HTML5 will not).

In the example file, the model is created with the global setting of red, and drawn in yellow (with the colour animating between black and yellow, and alpha animating between 1 and 0). In Windows, the model flashes on and off. On HTML5, the model remains yellow (as this was what the draw setting were when it was first drawn).

Mike Dailly

2018-07-27 16:22

Developer   ~0060947

Fixed in red - several commits - sample needs a font added for WebGL to display the text

a46ba257d6612ac41a88e82f6bf4ea313320a207
6f5bf6f8652e858c9ae4b3dfa099f6bf64a963b7
1b71fea75be6e1c71044a3e6d197cedfface3b0a
f97c41c4c2c18e41a039990e01efcb84df460902
645db1ebbf8b01c2c0316ba00fdeb78a0b119d66
a9570999b473651d39e44f1ca5229fcf549a5443