View Issue Details

IDProjectCategoryView StatusLast Update
0015625Runner[All Projects] FunctionsPublic2019-02-13 13:35
ReporterJon PetersonAssigned ToSteven Campbell 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionUnable To Reproduce 
Platform OS OS Version
Product Version 
Target VersionFixed in Version 
Summary0015625: Functions: timeline_moment_add_script seems to be broken
Descriptiontimeline_moment_add_script doesn't seem to work. All added scripts are executed on the same moment or never executed at all.

I've attached a gmz that has debug messages that illustrate the issue.

Also, there is a missing closing parentheses in the documentation for timeline_moment_add_script on the line with the choose() script.
Additional InformationOriginal helpdesk ticket: http://help.yoyogames.com/tickets/67232
TagsNo tags attached.
1.4 Found In1.3.1386
2.x Runtime Found In
2.x Runtime Verified In

Activities

Peter Carr

2014-08-07 17:18

Updater  

TimelineMomentTester.gmz (904,560 bytes)

Neil Wicker

2014-08-19 10:15

Updater   ~0031987

Reproduced in 1.4.1398 - assigned.

alexandervrs

2015-10-14 13:05

Updater   ~0039900

Still in 1.4.1657
HTML5 seems it works, it's broken for Windows, could be other platforms too.

NeutralD

2015-10-29 14:33

Reporter   ~0040047

Last edited: 2015-10-29 14:46

View 4 revisions

I've got the same problem in 1.4.1629.
Reproducible on Windows, Android, iOS without YYC.
It actually adds the moment since timeline_size() shows all 12 moments that I've added. But the time of the second and all following moments is incorrect (equals the time of the first moment). timeline_max_moment() in this case always shows the time of the first moment.
When I start the timeline it executes my script 12 times on the first moment.

xot

2017-06-22 16:38

Updater   ~0053756

Mark posted a workaround here:
http://gmc.yoyogames.com/index.php?showtopic=632939

Russell Kay

2018-05-14 11:52

Manager   ~0059664

Unable to reproduce in GMS2 - only issue is that the first 2 scripts execute because the timeline position is set to 0 and this is advanced to 1 so the initial script is not executed but this is realised when it hits the script_2 so it executes both scripts - the timeline_position should be set to -1 and then everything works fine

Dan

2019-02-13 13:35

Adminstrator   ~0063082

Mass-closing as per the Resolution of Unable To Reproduce and because many of these reports are very old / relate to GM: S 1.4.

If the comment from the dev above says this report was resolved because there was no sample, but you still have this issue in a CURRENT version of GMS2, please do submit a Helpdesk ticket and give us a sample project and we will add a new bug report with the fresh info.