View Issue Details

IDProjectCategoryView StatusLast Update
0014553Runner Suggestions[All Projects] FunctionsPublic2018-10-11 15:43
ReporterMark AlexanderAssigned ToMike Dailly 
PriorityVery LowSeveritySuggestionReproducibilityN/A
Status ResolvedResolutionDuplicate 
Summary0014553: Suggestion: Functions: Add draw_get_font() to the font functions [and draw_get_font_align()]
DescriptionThis was a suggestion made here http://gmc.yoyogames.com/index.php?showtopic=624248

Add a getter function for fonts to tell us which font is being used for drawing currently:

draw_get_font(); // returns the ID of the font resource
TagsNo tags attached.

Activities

rcusumano

2014-05-28 23:50

Updater   ~0029262

This would be nice for an isolated script to be able to switch the font for its own uses and then put it back.

I'd also suggest coupling this with draw_get_?align() for maximum usefulness.

ParodyKnaveBob

2014-05-29 13:23

Updater   ~0029275

I definitely agree with rcusumano's addition to this suggestion.

Fwiw, along with code that modularly bounces back and forth between font settings, these additional functions would also be very handy for debugging.

Pandaboy

2014-08-19 15:10

Reporter   ~0032013

I support this to 110%, and it deserves higher priority as it would be very useful and also seems like something that wouldn't be too hard to implement since it only needs to return a variable.

draw_get_font, draw_get_halign, draw_get_valign are just a few of the functions that would prove useful. Imho, if there is a set_ function there should also be a get_ function that returns the value. It is extremely useful in scripts where you're temporarily changing one of those values and at the end of the script want to change it back.

xot

2014-08-19 15:55

Updater   ~0032018

Totally agree and am strongly in favor of get/set parity in general.

TheMagician

2014-08-20 01:46

Reporter   ~0032028

Let me join in and say that this would be a nice time-saver.

Erik Leppen

2014-08-20 09:09

Updater   ~0032029

xot: that would be great indeed.

d3d_get_fog, d3d_get_culling, etc. :)

Don Arthuro

2015-12-24 14:53

Reporter   ~0041328

Any thoughts on when this can be expected? This would make life a lot easier.

tsa05

2016-12-29 19:43

Reporter   ~0050802

Proposing that this be merged with http://bugs.yoyogames.com/view.php?id=15941 which is a more complete list of reciprocal functions and currently is assigned HIGH priority