View Issue Details

IDProjectCategoryView StatusLast Update
0013381Runner Suggestions[All Projects] UIPublic2018-10-11 15:36
ReporteralexandervrsAssigned ToMike Dailly 
PriorityLowSeveritySuggestionReproducibilityN/A
Status ResolvedResolutionWon't Fix 
PlatformOSWindowsOS Version
Summary0013381: Suggestion: UI: [Swap extensions function dialogue argument drop-down for a two-way radiobox]
DescriptionI'd like to wish to make 'double' the pre-selected argument type when authoring extension functions (like in return type).
My problem is when authoring extensions which have lots of arguments, most of the time is of type 'double' than 'string', the list is really glitchy that I have to click like 3 times on each list item to get the dropdown to appear and change it to 'double', which makes Extension authoring tedious.
TagsNo tags attached.

Activities

Dan

2014-01-28 15:33

Adminstrator   ~0027195

Aside from being "glitchy" (not something I've seen, btw), I've never been sure why we have a drop-down for only two entries. A horizontal/flat radiobox would be a much better choice anyway and an actual fix for your issue, rather than swapping the default (which someone else might well object to).

alexandervrs

2014-01-28 18:21

Updater   ~0027203

Perhaps dropdown was chosen because it was expected to have more than 2 datatypes later on? (e.g. Array, Float etc.)

But yeah, the glitch I am experiencing is that I have to click around 3 times in each dropdown for it to appear and be able to change it. Perhaps is an issue of the dropdowns being inside a list?

Erik Leppen

2014-02-03 16:04

Updater   ~0027293

Last edited: 2014-02-03 16:59

View 2 revisions

The whole extension editing mechanism is horrible. I always use the XML files directly. Ever written an extension with 40 functions? Impossible to do without making mistakes and cursing if you use the IDE's extension editing mechanism. Just add one function and one constant, and do the rest in the XML file instead.

In fact if GM were my program I'd opt for a redesign of the whole extension editing mechanism. I'll put it in the GMC's suggestion box.

Edit: see my suggestion here: http://gmc.yoyogames.com/index.php?showtopic=609323