View Issue Details

IDProjectCategoryView StatusLast Update
00299911.4 IDE BugsDebuggerPublic2018-09-06 15:40
ReporterYellowAfterlifeAssigned ToAlan Savage 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ClosedResolutionFixed 
PlatformWindowsOSWindows 10 ProOS Version>=1703
Product Version1.4 Final 
Target Version1.4 FinalFixed in Version1.4 Final 
Summary0029991: Debugger: Watches panel is defunct
DescriptionIt appears that the Watches window had been broken since at least 2016, but so few people use it that no one reported the issue.
Steps To ReproduceRun a project (any works, but I attached a test just in case)
Put a breakpoint somewhere, run with debugger on
When the game pauses for breakpoint, switch any of the panels to Watches and try adding a variable to watch that is on Locals/Instance panels - no value shows up neither immediately, nor after stepping.
Change Watches panel type to something else and back - watches are not saved
TagsDebugger
1.4 Found In1.4.9999

Activities

YellowAfterlife

2018-09-02 08:58

Developer  

a_bug.gmz (568,137 bytes)
png3.png (44,082 bytes)
png3.png (44,082 bytes)

Dan

2018-09-06 15:40

Adminstrator   ~0061534

Works fine now in 9999 (pt 2). Closing.