View Issue Details

IDProjectCategoryView StatusLast Update
00299701.4 IDE BugsBuild AndroidPublic2018-08-24 12:39
ReporterDanAssigned ToFritz 
PriorityVery HighSeverityA - Crash/HangReproducibility100%
Status ClosedResolutionFixed 
Platform-OSWindows 10OS VersionPro x64
Product Version1.4 Final 
Target Version1.4 FinalFixed in Version1.4 Final 
Summary0029970: Build Android: Access Violation if any part of your GGS package name is blank and you try to run/compile
DescriptionYou will get an Access Violation if any part of your Android package name is blank in GGS and you try to run/compile. This is because the function which checks for an invalid name has no check for if the string it's about to check is blank.

This is very easy to get if your project name starts with a number (e.g., 3DTest), as this will give an invalid product name as far as Android is concerned (as it won't like com.companyname.3DTest) and so GGS blanks the third field in order to alert the user later on that they need to fix this issue.
Steps To Reproduce1. Create a project which starts with a number, or alternatively remove any of the fields for your Android package name in GGS for any project.
2. Ensure you have added a room, then try running this project for Android.
3. Observe the access violation.
Repro: 100%
TagsNo tags attached.
1.4 Found In1.4.9999

Activities

Dan

2018-08-24 09:09

Adminstrator   ~0061354

Last edited: 2018-08-24 09:09

View 2 revisions

Fritz has fixed already at the end of the day yesterday. 7e8df699919bfda41bd23394a19ae770cd8f695e

Dan

2018-08-24 12:39

Adminstrator   ~0061359

All good now. Closing.

Fixed.png (4,910 bytes)
Fixed.png (4,910 bytes)