View Issue Details

IDProjectCategoryView StatusLast Update
00299282.x IDE BugsBuild AndroidPublic2018-09-07 11:05
ReporterStewart BishopAssigned ToFritz 
PriorityMediumSeverityB - MajorReproducibility100%
Status ClosedResolutionFixed 
Product Version2.1.5 
Target Version2.2.0Fixed in Version2.2.0 
Summary0029928: Build Android: Building with Lint enabled will always fail unless you have Bluetooth permissions enabled
DescriptionIf you have "Run Lint Code Analysis" enabled without "Enable Bluetooth/iCade Support" you'll receive the following error in your lint report:

 ../../src/main/java/com/company/game/Gamepad/Gamepad.java:227: Missing permissions required by BluetoothDevice.getName: android.permission.BLUETOOTH

 224 {
 225 // if device (or its name) is null then return...
 226 if (bd == null) return;
 227 if (bd.getName() == null) return;

 228
 229 Log.i("yoyo","BluetoothDevice connected " + bd.getAddress());

Note: This issue has an associated quickfix operation in Android Studio/IntelliJ
Priority: 9 / 10
Category: Correctness
Severity: Error
Explanation: Missing Permissions.

Expected would be that by default you don't need the bluetooth permission since there's no indication that you're ever going to even use gamepads.
Steps To Reproduce1) Create a project
2) Open Android Game Options
3) Enable lint
4) Run on Android
5) See that this fails
6) Enable Bluetooth permission
7) Run again
8) See that this now works
Tags1_4_final, android, Compiler, IDE
2.x IDE Found In2.1.5.322
2.x Runtime Found In2.1.5.246
2.x IDE Verified In2.2.0.334
2.x Runtime Verified In2.2.0.252

Activities

Dan

2018-09-07 11:05

Adminstrator   ~0061549

Fix is in 1.4.9999 also.