View Issue Details

IDProjectCategoryView StatusLast Update
0029763RunnerAudioPublic2018-10-12 11:55
ReporterStewart BishopAssigned ToPeter Hall 
PriorityMediumSeverityC - GeneralReproducibility100%
Status ResolvedResolutionFixed 
Product Version2.1.4 
Target Version2.2.0Fixed in Version2.2.0 
Summary0029763: Audio: Crackling occurs if you set an emitter's velocity
DescriptionIf you set the velocity of an emitter, then the audio won't sound as expected and instead will crackle.
Steps To Reproduce1) Run the sample
Tags1_4_final
1.4 Found In
2.x Runtime Found In2.1.5.238
2.x Runtime Verified In

Relationships

related to 0029817 ResolvedPeter Hall Audio: Clicking occurs if you change the pitch of an emitter 

Activities

Stewart Bishop

2018-07-06 14:03

Adminstrator  

doppler_test.yyz (55,946 bytes)

Peter Hall

2018-08-16 11:10

Developer   ~0061273

we were using the wrong pitch value when mixing sounds in

Dan

2018-10-12 11:52

Adminstrator   ~0061753

Last edited: 2018-10-12 11:55

View 2 revisions

Note that the reporter says we stopped the crackle but also inadvertently removed some intended functionality as a result of this fix - https://forum.yoyogames.com/index.php?threads/gms2-version-2-2-0.53732/page-2#post-329786

Will review the change internally before we close this report.